Migration Notes Overview

This document informs you in detail about incompatibilities that were introduced between different Axon.ivy versions and tells you what needs to be done to get your existing projects working with the newest Axon.ivy version.

Please note:

  1. Changing from an older Axon.ivy version to a newer one requires you to perform the necessary migration steps one after another from the oldest to the newest one.
  2. If deployed Axon.ivy projects are not compatible with a new Engine version then you will have to convert them first on the Axon.ivy Designer and then redeploy them to the upgraded Engine installation afterwards.

Xpert.ivy becomes Axon.ivy

With version 5.1 the product was renamed from Xpert.ivy to Axon.ivy. Moreover, the Xpert.ivy Server was renamed to Axon.ivy Engine.

If previous versions of the product are referenced in this document then still the old names Xpert.ivy and Server are used.

Migrating Axon.ivy Projects

When we speak about migrating the Designer, we mean in fact Axon.ivy Projects in your workspace (or inside an SVN repository). It might be that the default structure of a project has changed, that the storage format of some artifacts has been altered or that new configuration files have been introduced with a new Axon.ivy version.

Usually, all of those incompatibilities can be resolved automatically by invoking the project conversion in the Designer. Sometimes, however, it is necessary that you perform some changes manually. This document and it's sub documents will guide you through this process.

Deprecated Public API

When migrating your projects check whether you are using deprecated Public API. Replace the usage of the deprecated Public API with the new Public API provided instead.
Deprecated Public API may be removed in future versions!

Migrating an Engine Installation

To learn how to upgrade/migrate an Engine please read the Installation chapter of the Engine Guide.

If you upgrade to a new update release within the same Long Term Support (LTS) or Leading Edge (LE) version (e.g. 7.0.3 to 7.0.4) then normally you do not have to do any migration steps at all. Simply follow the procedure given in the Installation chapter.

Migrating an Engine usually implies a conversion of the system database. This can be resolved automatically by invoking the system database conversion in the Engine Configuration Tool.

Project Conversion

If deployed Axon.ivy projects are no longer compatible with a new Engine version then it is currently not possible to convert them on the Engine. Therefore you need to load all projects deployed to active process model versions into the Designer, convert and migrate them individually and re-deploy them to the same process model version.

Update Apache Tomcat Connector

If the Axon.ivy Engine is integrated with a reverse proxy (e.g. IIS or Apache), it is best practice to check if the most recent Apache Tomcat Connector is installed. For further information look at Update Apache Tomcat Connector.

Migrating a Leading Edge Version

If you migrate a Leading Edge (LE) version then also read the migration notes for the older Long Term Support (LTS) version to the newer LTS version. For example, you have a Leading Edge version 6.3 then also read the migration notes for migrating between LTS version 6.0 and LTS version 7.0.

Migration steps that are necessary for all versions (LTS and all LE versions) are marked with:

Migration needed for all versions

> Execute this migration step.

Migration steps that are not necessary for certain Leading Edge versions are marked with:

Migration not needed for 6.3..7.0

> Execute this migration step if you have 6.0, 6.1 or 6.2. Do not execute if you have 6.3, 6.4, 6.5, 6.6 or 6.7.

Migration steps that are only necessary for certain Leading Edge versions are marked with:

Migration only needed for 6.3..7.0

> Execute this migration step if you have 6.3, 6.4, 6.5, 6.6 or 6.7. Do not execute if you have 6.0, 6.1 or 6.2.

Migrate 7.0 (Jakobshorn) ... 7.1 (Weisshorn)

Read the migration notes of

Migrate 6.0 (Säntis) ... 7.0 (Jakobshorn)

Read the migration notes of

If you are migrating from a 6.x Jakobshorn Leading Edge version this migration notes is also for you.

Migrate 5.1 (Lauberhorn) ... 6.0 (Säntis)

Read the migration notes of

Migrate 5.0 (Rothorn) ... 5.1 (Lauberhorn)

Read the migration notes of

Migrate 4.3 (Pilatus) ... 5.0 (Rothorn)

Read the migration notes of

Migrate 4.2 (Rigi) ... 4.3 (Pilatus)

Read the migration notes of